WordPress 5.0, older versions and Gutenberg

Published on December 21st, 2018

WordPress 5.0, older versions and Gutenberg

Earlier this month WordPress launched 5.0 which includes Gutenberg as standard. A security release of 5.0.1 and 5.0.2 was launched a few days later. As with STORM we always installed the latest version of WordPress. You can find out more about Gutenberg.

Our client services team have received feedback from clients asking us to offer both WordPress 4.9 and 5.0 on creation of a new web site in STORM. This posed an interesting question as we offer the same flexibility for Magento with version 1.9 and 2.0.

Our development team investigated this as an option going forward but WordPress stop support for older versions once a newer version has been released. You can find more information about WordPress supported versions.

As part of the principles of STORM is best practice we feel that we cannot offer the installation of an application that is potentially insecure.  We realise that Gutenberg can be quite different from the previous editor and therefore confusing for end users. As an alternative we recommend taking a look at the Classic Editor.

Newsletter Signup

Signup to the STORM News for regular updates